Cannot connect wires to pins

I noticed there weren’t any 3PDT switches in the library so…, I made my own. First time creating an element in this program. Done one or two in LTSpice but, this wasn’t the same. I started by creating my own library, as advised in other threads that I had perused before embarking on this adventure then, one by one, I created each sub component. Everything looked good and I was sure it was gonna work but, it didn’t quite cut the mustard. Is that the right saying? Lol! Anyway, attached is a pic of the component in my circuit. Notice how only the middle bottom pin seems to be able to connect to a wire. I can share the component if someone can tell me what I have to do so you can inspect it. Give you more details when needed. Thanks again, and I knew it wouldn’t be long before I was back again to make all your lives a living hell.:slight_smile:

So you know, them green wire traces are only there to highlight how the traces aren’t making an electrical connection when connected to the pins.

You need to assign a signal to the pins.

please open your component, and under “symbol variants” open the default variant to edit:
Bildschirmfoto 2023-12-31 um 18.59.33

then assign a signal, don’t leave it to “unconnected”

you need to update the project library in your schematics afterwards.

That was it. Took a minute to figure out exactly what sub section you were at but, I got there. One last thing. When I check out my design in the 3d view, I have a 6 pin header where it’s just supposed to be solder pads. Probably an easy fix and i will look into it a little more but, any help would be appreciated. Thanks again.

I guess you reused one of the Packages of the official library. That way you also made a copy of the embedded 3D model.

So please open your package from the library manager, switch to the 3D mode and delete the existing 3D model of the 6 pin header by clicking the “-” (top, middle)

You can also add a new 3D model that suits your needs if you like.

BTW: Happy new year to all that read this!

Ok. I think I figured it out. At first, deleting that pin header model as described above didn’t work. I got the following error message.

Missing Device or Package Error

I then did some snooping around and eventually remembered from the videos, and then verified for myself, that not all the components in the base library have a device associated with them so…, I decided to just delete the “Device” sub-component. The funny thing is, it did actually work on the project I was working on but…, on other tests, it gave me that same error message again. After some more banging my head against a wall, I thought that maybe it’d be a good idea to just redo the device sub-component again. I tried in vain to find a suitable model that resembled what I was looking for as you suggested, when I realized that maybe I could just use the same “package” that I already had (the 6 pin header file that I turned into a 9 pin header). So far, that seems to have done the trick. I have closed and reopened my projects a few times, updating my local library each time and even restarted LibrePCB and so far, so good. Check out the 2 quick tests below.

And finally, I decided to do some housekeeping on my projects and ended up realizing that I did a piss poor job of naming everything, so eventually I decided to just redo my tester from scratch again. I haven’t done the wire traces yet but, at least my 3PDT Switch is exactly as I want it so…, I think we got a winner! Thanks so much once again. As a side note, I do have 3D modeling experience, I may do some models for the DPDT and 3PDT switches when I get a minute. Until then, thanks again and…, i’m sure i’ll be back.

Ok, so you had a lot of work for a 1st of the year… :wink: …glad you managed it.
Regarding that error-message: I can’t tell what was causing that, sorry.

I don’t have a suitable 3D model for your switches, but if you like you could use my DIP8 model to complete your board. Hope that the board software allows this: (24.4 KB)

Thank you. I will try it out. Be a minute before I get around to doing any 3d modeling. Got a lot on my plate. I just hope my software can output step files, as that is what LibrePCB seems to be wanting. Hopefully it’s a standard file format. Anyone know? Guess i’ll find out soon enough. Anyway, I hope you all had a happy new year and i’m sure you’ll see me again soon. Lol! Thanks again.

You‘re welcome.