Eagle import

Maybe I’m being a bit thick (probably) but I can’t find how to import anything from Eagle. I’m using 1.0.0-rc1 and 0.1.7

I assume Eagle libraries are supported - what about schematics & boards?



The Eagle library import is in the library editor (create a local library first):


Importing schematics and boards is not possible so far.

Excellent! Thanks for that… I have another question that’s unrelated (but still import/export), so I’ll do that in another thread,

1 Like

When I try to import my Eagle library, LibrePCB 1.0 exits silently! You are welcome to a copy of the Eagle library to see if you can duplicate the issue.


Then I see this, after which it exits silently…

(image removed as I am a new user so can only have one embedded image in a post)
Event viewer:
Faulting application name: librepcb.exe, version:, time stamp: 0x64e37343
Faulting module name: libstdc+±6.dll, version:, time stamp: 0x00000000
Exception code: 0x40000015
Fault offset: 0x000bb534
Faulting process ID: 0x0x4B9C
Faulting application start time: 0x0x1D9DF652AFF18A6
Faulting application path: C:\Users\nick\Downloads\librepcb-1.0.0-rc1-windows-x86\bin\librepcb.exe
Faulting module path: C:\Users\nick\Downloads\librepcb-1.0.0-rc1-windows-x86\bin\libstdc+±6.dll
Report ID: 8d653a7f-f832-4b88-84f6-e775a44f9eb1
Faulting package full name:
Faulting package-relative application ID:

There’s other stuff in the Event Log related to this but I can’t see how to embed XML in my reply without making an awful mess!

Huh, that’s not good :sob:

I upgraded your user account, are you now able to attach the Eagle library as a ZIP file (only ZIP is allowed) by drag&drop into the text input field?

I would prefer not to make the library publicly available at the moment as there is some commercial stuff in there. Can I send it to you directly/privately?

That’s fine, please send it to the e-mail shown at Contact | LibrePCB.

You have mail!

I got it and tried to import it, but everything works fine. I also tried on Windows, no issue found. Both with LibrePCB 0.1.7 and 1.0.0-rc1.

Did you try it a second time and it happened again? At which step did it crash?

Rats! It was a silent crash so I don’t really know… I’ll do some tests tomorrow - it’s getting late here…

1 Like