ERC Not Showing My Devices as Unplaced

The Problem:

Devices I have create. That is: Component Categories, Symbols, Components and Devices are not showing in the PCB editor for placement, only LibraPCB native devices are placeable.

I Have successfully managed to create a simple circuit diagram from one of my devices and two native devices. I do see the native devices in the ERC side panel (showing as unplaced) but not my device.

What have I done wrong please?

Regards to all.

If I understand correctly your description, it looks as a missing package for your component and not created link (package with component) for your device in the library.
Also uncheck the ‚ÄúSchematic-Only‚ÄĚ check box in your Component in the library (if you have checked).

After this you will see an unplaced device in the PCB editor, if your component is placed in the schematic editor.

Thank you for responding and valuable help.

The problem was the ‚ÄúSchematic Only‚ÄĚ check box which I had checked and obviously totally misunderstood its purpose.

So to clarify my understanding and any one else for that matter:

If the schematic representation is ONLY relevant to the circuit diagram then check ‚ÄúSchematic Only‚ÄĚ box. So what is and is not ONLY relevant to the circuit diagram? If the component represents a physical device on the PCB then leave the check box unchecked.

Often there are elements on the circuit diagram used to make the diagram easer to read, These are On and Off Sheet Net connections, A Notes panel, Voltage at a Node or Current Measurements for fault find or set-up. To mention a few.

Regards to all and thank you for a fantastic tool. I’m looking forward to further improvements.

2 Likes