Grid Snapping

Evening all. I’m trying to draw an outline around a package and can’t seem to figure out how to stop the square from snapping to the grid, which is a 2.54mm grid. If I increase the grid resolution its going to fry my eyeballs.

OK. So I’ve figured out that you can’t turn off snapping but you can increase and reduce grid resolution and it doesn’t affect work already done.

Doing this via the Grid button however is really slow. Can this item be pinned to the button bar or even better can we have a keyboard shorcut for it? -Mousewheel for instance?

As a workaround you can also place the objects on the grid, and then double-click them and edit the coordinates by hand.