Inconsistent Plane Functioning and Add Vertex to Plane Not Available

  1. Create a new project.
  2. Add capacitor and a ground symbol. Connect them in the circuit diagram.
  3. Placed on the board but not routed.
  4. Add Plane functions. (Signal = GND, Layer=Top Copper)
  5. Draw a rectangle starting top left then top right, next bottom right finally bottom left.
  6. Select the arrow tool.
  7. Click on each line in turn to show pop-up selection and that “Add Vertex”. Should fail on left hand line. (BUG: Unable to add vertex to plane.)
  8. Delete components from the board and circuit.
  9. Add Plane shows parameters but reports “Logic Error” when trying to draw a plane. Note Signal Property is blank and no other selection is available. (BUG: Inconsistent functionally. When a new project is created this function is disabled.)
  10. Re-create the previous capacitor and GND circuit.
  11. Go to the board editor. Add the capacitor to the board.
  12. Select Add Plane and ensure the Signal is GND also change the Layer to the Bottom Copper.
  13. Trying to add a plane fails reporting “Logic Error”.
  14. Change the Layer to Top Copper and retry Add Plane also fails with “Logic Error”. (BUG: Inconsistent functionality. This worked in step 4.)

Has any one else been able to reproduce these errors? Or should I just try to add this to the Git Hub Error Reporting?

Thanks for the detailed report. I haven’t yet tried to reproduce it, but from your description it seems like a bug.

Could you maybe open an issue on the GitHub project page?

Done: Inconsistent Plane Operation and Add Vertex to Plane Not Available #828