Help On Plane Properties Connect Style

I scratching my head as to the intended purpose of setting ‘Plane Properties’, ‘Connect Style’ to ‘None’. I can see the benefits of not having the plane filled or hidden when routing other signals but there is a separate UI control for just that purpose.

‘Solid’ I understand but ‘None’ is a mystery.

If you manufacture a PCB with a PCB mill or by self-etching, you may want to have an unconnected plane so that the milling head or the etchant have less work to do.

Sorry I’m not sure I follow your explanation. Surely one has a plane for a reason: a low impedance path, screening, providing a Heat-sink for example. The point is, they and connected, I personally and from experience can not think of a reason why a plane would never be connected some where .

The option name “Connection Style” and a bit of code digging suggests it’s associated with the connection between the plane and any device pin on the same net. That is; not connected (None) or fully connected (Solid), the connection could of coarse be a thermally relived connection (an option not currently available) but that takes this off topic.

As mentioned I did do a bit of code digging and I think I found a bug with the None option. First I’m assuming when Plane Rebuild is selected it should fully fill the plane regardless of the Connection Style ( a bug? ). This would make sense since there is a separate UI control to hide (right click visible) the plane for easier trace editing.

I have also discovered by adding a trace from any device pin on the same net as the plane and for a short distance, say 1mm, then the None option and Rebuild Plane selected result in a clearance around pads. This provides some interesting possibilities. See the simple picture below.


Having to add an overlapping trace suggests a second bug.

Sorry dropped the image:

Yes, you got it! :slight_smile:

One thing to note is that with connection style “none”, the copper area might disappear if no traces are located within it. In this case, you might want to enable the checkbox “Keep orphans”. But of course then you could have copper areas which are not connected to a signal at all…

Thanks for the confirmation, appreciated, and I didn’t realise the “Keep Orphans” trick in this case.

I’m not sure what the team’s intentions are on this functionality (None and the plane not being filled) but would anyone object if I raised an improvement request? If I didn’t follow what was happening I’m sure other don’t.