Naming of Supply Pins

Do we want guidelines on naming of power pins?

For example, in the Sensirion SHTC3 datasheet, the power pins are called VDD and VSS (using the FET naming convention). In the symbol, we picked VCC and GND instead, for consistency with other ICs.

img

However, the SGPC3 has an additional “hotplate supply voltage” pin which is called VDDH:

img

Should we strive for consistency within the library, or should we use the terminology that is used in the manufacturer datasheet? If we don’t want to use the VDD/VSS terminology, do we call de hotplate pin “VCCH”, or something else?

I’m starting to think that using the terminology from the datasheet might be easier to implement consistently…

We must match the data sheet for all devices. No exceptions. So each device needs a component with the correct names.

But we also need a library of generic parts with no devices that the user will later assign to a device. We need a naming standard for these symbols. They should all have have a consistent look and feel.

The same symbol will be used for both but the name can change when the component is swapped for one that has a device.

That’s a good obervation!

What about this approach?

For device-specific symbols or components, try to match the names used in the datasheet.

For generic symbols or components, prefer using VCC and GND to name supply pins, not VDD and VSS, unless there is good reason to deviate from that standard.

If the generic symbol or component has both digital and analog ground pins, use DGND and AGND.

I’m not sure if the last part makes sense, I don’t have much experience with parts that have separate digital / analog ground nets.

That looks good. VCC and GND were common in the 70’s when everything was NMOS and used TTL level signaling. VDD and VSS came later as the industry moved to CMOS. If we have to pick one then VCC/GND would be best.

VCC is no longer assumed to be +5 volts. It is whatever the logic family that you are using says it is.

We should also consider supporting multiple pins with the same name. That is common in the industry and if the data sheet has five pins all named GND then we shouldn’t change them to GND1,GND2 etc.

I believe LibrePCB already supports this but issues a DRC warning. We should get rid of that warning and support this feature.

1 Like