Unable to download LibrePCB using Win 10

When I try to download a opy of LibrePCB onto a Windows 10 Desktop all I get is a page of gobbledegook. The only thing that made sense was the words “Does not work on DOS” which wasn’t very helpful. What am I doing wrong? I have used Libre Office for a while and found it easy to download and to use.


Should be fixed now! It seems the HTTP header content-type was not set properly, which caused MS Edge to open the files instead of downloading them. Now it is set to application/octet-stream for binary files.

Please try again and let me know if the problem still exists.

1 Like

Thanks for the reply Ubruhin. I am now as confused as ever. As an experiment I went on the website and using the Installer for windows option successfully downloaded LibrePCB onto an old Window 7 Pro machine. Worked first time. I then tried the same thing on a Win 10 Pro machine using the Installer for windows option and got the same load of gobbledegook as before. I then tried the Portable Zip option and downloaded the Bin and Share files. I unzipped the Bin file to give a load of seperate files. I then tried to run the librepcb.exe file, which MS Defender did not like. I the opted for the Run anyway option. The result was Code execution cannot proceed because QT5Gui.dll not found . However the file is clearly listed in the files shown with a size of 9.689.784.

So I am happy that I can at least run the LibrePCB program, but not apparently on a Win 10 PC.
I am no expert on computers so may have done something wrong in which case I can only apologise. Thanks again for your efforts. Clockwork

Hmm ok this is strange, I cannot reproduce the download issue anymore, even on Win10. Which web browser are you using? Or maybe it’s simply a caching issue? Maybe you could try to clear the web browser cache somehow…

And I also cannot reproduce the issue with the Zip - I just downloaded, extracted and run it successfully on Win 10 :thinking:

Hi Ubruhin,
I am using the latest version of Chrome on a Win 10 Pro 64bit PC. I cleared all the data and cache for chrome and then it all worked fine. I havent tried using the Zip method as it all worked. Many thanks.
Now to learn how to use LibrePCB to produce PCB’s on a CNC mill/engraver

1 Like