Updated symbol/component not shown in library


I am trying to learn how to use the library manager/editor to create a new device (a LCD display). I created a new symbol/component/package/device, following the guide in the documentation. Then I discovered that I had forgotten to add a few signals/pins to the symbol and component. I went back and updated the symbol and component, but those changes did not appear in my device. I even tried deleting the device and creating a new one, but when I selected my updated component in the library manager, the new signals/pins were not there. Am I missing something?


I’m not sure if I understand correctly. Did you already add the component to a schematic, and modified it afterward in the library? If that’s the case, you need to update the project’s library (menu item project -> update library), but probably that won’t work if you added new signals to the component. In that case you have to remove all instances of that component from the schematic, and re-add it afterwards.

If this doesn’t help, please provide some more details about what you are doing and what doesn’t work exactly :slight_smile:


What I did was basically this:
I created a new symbol/component/package/device according to the LibrePCB documentation. I may have added the component to a schematic or not, I do not quite remember. But my issue here is only within the library editor itself, not the schematic editor.

Anyway, after creating the device I noticed that I had forgotten to add some signals. So I went back to the symbol editor and added them, and then added the signals to the component (by opening the component editor and clicking the ±symbol in the Signals list, giving them the same name as in the Symbol editor (not sure if this is the correct way?). Then when I opened my device to add the new signals to the Pad-Signal map my new signals were not there. The symbol in the component view in the device editor had not changed either, so my new signals were not visible there. I even tried deleting the device, creating a new one, but that did still not show my newly added signals.

I hope that demonstrates the issue more clearly.

Ah, I see. Since the symbol was modified, you need to update the component symbol variant (with the pin-signal-map) too. In the component editor, open the symbol variant dialog with this button:


Then you probably need to remove the symbol from this list:

And re-add it afterwards to get the updated pin-signal-map in the table below. In that table you then need to adjust the mapping of pins accordingly.

Ah yes! That was the dialog window I was having the feeling I needed to access, but could not find it. I started all over because I needed to change a few other things, but now I know for next time this pops up. Excellent, thank you for your help.