LibrePCB on Debian Buster X86 64 intel-i5 CPU

Dear all,
I am trying to install LibrePCB on a laptop running Raspbian X86 Buster which is a Debian Buster with additional technical software as used on the RPi Raspbian OS (Debian with Raspberry Pi Desktop).

I have followed the instructions in the LibrePCB manual for Linux installation:

wget "https://download.librepcb.org/releases/0.1.3/librepcb-installer-0.1.3-linux-x86_64.run" chmod +x ./librepcb-installer-0.1.3-linux-x86_64.run
$ ./librepcb-installer-0.1.3-linux-x86_64.run

When I execute the third command line, the output is:
bash: ./librepcb-installer-0.1.3-linux-x86_64.run: No such file or directory

For finding the reason I tried:
$ file librepcb-installer-0.1.3-linux-x86_64.run
which outputs:
librepcb-installer-0.1.3-linux-x86_64.run: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.18, BuildID[sha1]=1b3319ea2c48f23f05faab61b9dedd9343040aee, stripped

Then I tried:
$ ldd librepcb-installer-0.1.3-linux-x86_64.run
which outputs: not a dynamic executable

My laptop is with a Intel® Core™ i5-7200U CPU @ 2.50GHz

$ cat /proc/version
outputs:
Linux version 4.19.0-6-amd64 (debian-kernel@lists.debian.org) (gcc version 8.3.0 (Debian 8.3.0-6)) #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11)

Have any of you succeded with a LibrePCB installation on a Debian Buster ? And how?

Br, Olav

Can you post the output of uname -a?

I suspect you’re running a 32bit system (x86) instead of 64 bit (x86_64).

Hi Danilo,

Thank you for your response - no I have already checked that, and I am running a 64 bit system. Output for uname -a is:

Linux raspberry 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64 GNU/Linux

My laptop is with a Intel i5 CPU and the Linux kernel is for AMD64 - could that be the reason? I have installed a lot of programs on it, and this is the first issue I have had. Else it has been running rock solid.

I wish LibrePCB was available at the Debian repository as LibreCAD, so installation and updating was easy.

Br, Olav

Hmm, maybe a difference in the binary format? What’s shown if you call file for another binary on your system?

Yes, that would be great. So far, nobody with experience in Debian packaging has volunteered so far, although I’ve read of some attempts in the LibrePCB development chat… Maybe someone will release proper Debian packages soon.

Do you have https://www.flatpak.org/ installed? In that case, you could also install LibrePCB from FlatHub.

Hi again,

I have downloaded the Nvidia linux driver package for Linux x86-64 systems for testing another binary file and when running the “file” command I get this output:

NVIDIA-Linux-x86_64-440.59.run: POSIX shell script executable (binary data)

I will try using the flatpak installation - thanks

Br, Olav