Linux: SQL errors after installing

Being a long-time unsatisfied user of contemporary EDA packages, I though I’d give this one a go. The library architecture aligns 95% with my expectations, which is on par with Horizon (which I didn’t like because of other reasons) and more than any other package (like Kicad).

I followed the “Online installation” instructions for Linux, but after I run it and define my workspace folder, everything I do creates SQL errors and I can’t get anything useful done.

I understand this project is just over a year old and still somewhat immature. This makes me wonder if anything I did was unexpected by the developers (i.e. I changed all the default folders) or if I’m missing essential dependencies that the installer overlooked?

This screen recording explains it all:

NB. It doesn’t matter if I wait for the “Scanning libraries” bar to finish or not, and it doesn’t matter how many or few stock libraries I choose to download.

Huh, that’s very strange. I’ve never seen these errors before.

@ubruhin do you have an idea what could cause this?

@Zom-B could you launch LibrePCB in the terminal and paste the terminal output here? There should be some debug messages.

zom-b@zomb-pc-2019:~/Desktop/LibrePCB/stable/bin$ ./librepcb
Load stroke font: "newstroke.bene"
Start loading font "/home/zom-b/Desktop/LibrePCB/stable/share/librepcb/fontobene/newstroke.bene"
[  INFO   ] "LibrePCB 0.1.3 (56bc60d347ff67df0fe1d57807d03f0606de557f)" (:0)
[  INFO   ] "Qt version: 5.12.3 (compiled against 5.12.3)" (:0)
[  INFO   ] "Resources directory: /home/zom-b/Desktop/LibrePCB/stable/share/librepcb" (:0)
[  INFO   ] "Application settings: /home/zom-b/.config/LibrePCB/LibrePCB.ini" (:0)
[DEBUG-MSG] Started network access manager thread. (:0)
[DEBUG-MSG] Load workspace settings... (:0)
[DEBUG-MSG] Workspace settings successfully loaded! (:0)
[DEBUG-MSG] Load workspace library database... (:0)
[DEBUG-MSG] Workspace library database successfully loaded! (:0)
[DEBUG-MSG] Workspace library scanner thread started. (:0)
[DEBUG-MSG] Workspace library scan started. (:0)
[ WARNING ] QSqlDatabasePrivate::removeDatabase: connection 'ffffffff-ffff-4fff-bfff-ffffffffffff' is still in use, all queries will cease to work. (:0)
[ WARNING ] QSqlDatabasePrivate::addDatabase: duplicate connection name 'ffffffff-ffff-4fff-bfff-ffffffffffff', old connection removed. (:0)
[DEBUG-MSG] Workspace libraries indexed: 9 libraries in 15 ms (:0)
[DEBUG-MSG] Successfully loaded font "/home/zom-b/Desktop/LibrePCB/stable/share/librepcb/fontobene/newstroke.bene" with 2573 glyphs (:0)
[ WARNING ] QSqlQuery::prepare: database not open (:0)
[DEBUG-MSG] "Driver not loaded" (:0)
[DEBUG-MSG] "Driver not loaded" (:0)
[EXCEPTION] Error while preparing SQL query: SELECT version, filepath FROM libraries (../../../../libs/librepcb/common/sqlitedatabase.cpp:157)

Another reason why I want to test out LP is because it’s one of my dreams to own/create/work on the perfect EDA package. If I’m satisfied I might consider becoming a developer. Also see

Hi @Zom-B,

That’s indeed a strange issue :frowning: Which Ubuntu version do you use? I’ll then try to reproduce it in a VM.

Just Ubuntu 18.04LTS. Let me reproduce it in a VM first then, which will save you some time.


I ran it in a VM, as well as at work on a PC with a much older and more ‘dirty’ Ubuntu 18.04 LTS, and both work fine. It’s just my PC at home giving these errors.

Okay, strange. You could try following things to investigate this issue (in arbitrary order):

  • Just deleting the workspace and creating a new one doesn’t fix the issue, right?
  • Try the AppImage instead of the installer - do you get the error too?
  • Install the package qt5-default (sudo apt install qt5-default) - although Qt is already bundled with LibrePCB, this might install some additional packages which are not bundled properly in the installer.

All options were unsuccessful. I’m now going to attempt setting up a dev environment to see if I step though the problem.

Okay, compiled from source ( master branch) it runs flawlessly.

Case closed. It wasn’t a problem with LibrePCB, or Ubuntu, but this:

Oh wow, that’s crazy! :flushed:

Whoa, yep, that’s pretty crazy indeed…

The Dilbert strip that someone posted in the comments is very fitting :slight_smile:

1 Like

That’s what I love about digital. No matter how crazy the symptoms seem to be they all make sense once your discover root cause.